Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 1 | ############################################################# |
| 2 | # |
| 3 | # cvs |
| 4 | # |
| 5 | ############################################################# |
Martin Banky | 82ab8b3 | 2010-09-26 00:13:57 -0700 | [diff] [blame] | 6 | CVS_VERSION = 1.12.13 |
| 7 | CVS_SOURCE = cvs_$(CVS_VERSION).orig.tar.gz |
| 8 | CVS_PATCH = cvs_$(CVS_VERSION)-12.diff.gz |
| 9 | CVS_SITE = $(BR2_DEBIAN_MIRROR)/debian/pool/main/c/cvs/ |
| 10 | CVS_DEPENDENCIES = ncurses |
Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 11 | |
Martin Banky | 82ab8b3 | 2010-09-26 00:13:57 -0700 | [diff] [blame] | 12 | CVS_CONF_ENV = cvs_cv_func_printf_ptr=yes |
| 13 | |
| 14 | CVS_CONFIGURE_ARGS=--disable-old-info-format-support |
Bernhard Reutner-Fischer | 8ff8fa7 | 2007-02-06 11:22:50 +0000 | [diff] [blame] | 15 | ifeq ($(BR2_PACKAGE_CVS_SERVER),y) |
| 16 | CVS_CONFIGURE_ARGS+=--enable-server |
| 17 | else |
| 18 | CVS_CONFIGURE_ARGS+=--disable-server |
| 19 | endif |
| 20 | ifeq ($(BR2_PACKAGE_ZLIB),y) |
| 21 | CVS_CONFIGURE_ARGS+=--with-external-zlib |
| 22 | endif |
| 23 | |
Martin Banky | 82ab8b3 | 2010-09-26 00:13:57 -0700 | [diff] [blame] | 24 | CVS_CONF_OPT = $(CVS_CONFIGURE_ARGS) |
| 25 | |
| 26 | define CVS_BZIP_UNPACK |
| 27 | $(BZCAT) $(@D)/cvs-$(CVS_VERSION).tar.bz2 | tar -C $(BUILD_DIR) $(TAR_OPTIONS) - |
| 28 | rm -f $(@D)/cvs-$(CVS_VERSION).tar.bz2 |
| 29 | endef |
| 30 | |
| 31 | CVS_POST_PATCH_HOOKS += CVS_BZIP_UNPACK |
Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 32 | |
Bernhard Reutner-Fischer | 647dbee | 2007-05-08 15:17:41 +0000 | [diff] [blame] | 33 | ifneq ($(CVS_PATCH),) |
Martin Banky | 82ab8b3 | 2010-09-26 00:13:57 -0700 | [diff] [blame] | 34 | define CVS_DEBIAN_PATCHES |
| 35 | if [ -d $(@D)/debian/patches ]; then \ |
| 36 | (cd $(@D)/debian/patches && for i in *; \ |
Bernhard Reutner-Fischer | 956d3eb | 2007-08-22 09:56:41 +0000 | [diff] [blame] | 37 | do $(SED) 's,^\+\+\+ .*cvs-$(CVS_VERSION)/,+++ cvs-$(CVS_VERSION)/,' $$i; \ |
| 38 | done; \ |
| 39 | ); \ |
Thomas Petazzoni | 59a326b | 2011-08-31 23:35:04 +0200 | [diff] [blame] | 40 | support/scripts/apply-patches.sh $(@D) $(@D)/debian/patches \*; \ |
Bernhard Reutner-Fischer | 8ff8fa7 | 2007-02-06 11:22:50 +0000 | [diff] [blame] | 41 | fi |
Martin Banky | 82ab8b3 | 2010-09-26 00:13:57 -0700 | [diff] [blame] | 42 | endef |
Bernhard Reutner-Fischer | 8ff8fa7 | 2007-02-06 11:22:50 +0000 | [diff] [blame] | 43 | endif |
Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 44 | |
Martin Banky | 82ab8b3 | 2010-09-26 00:13:57 -0700 | [diff] [blame] | 45 | CVS_POST_PATCH_HOOKS += CVS_DEBIAN_PATCHES |
Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 46 | |
Martin Banky | 82ab8b3 | 2010-09-26 00:13:57 -0700 | [diff] [blame] | 47 | define CVS_INSTALL_TARGET_CMDS |
| 48 | install -D $(@D)/src/cvs $(TARGET_DIR)/usr/bin/cvs |
| 49 | endef |
Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 50 | |
Thomas Petazzoni | 300f9c9 | 2011-09-29 21:57:43 +0200 | [diff] [blame] | 51 | $(eval $(call AUTOTARGETS)) |
Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 52 | |
Mike Frysinger | c94c036 | 2005-09-09 04:36:23 +0000 | [diff] [blame] | 53 | |