| ############################################################# |
| # |
| # udev |
| # |
| ############################################################# |
| UDEV_VERSION = 181 |
| UDEV_SOURCE = udev-$(UDEV_VERSION).tar.bz2 |
| UDEV_SITE = $(BR2_KERNEL_MIRROR)/linux/utils/kernel/hotplug/ |
| UDEV_INSTALL_STAGING = YES |
| |
| # mq_getattr is in librt |
| UDEV_CONF_ENV += LIBS=-lrt |
| |
| UDEV_CONF_OPT = \ |
| --sbindir=/sbin \ |
| --with-rootlibdir=/lib \ |
| --libexecdir=/lib \ |
| --with-usb-ids-path=/usr/share/hwdata/usb.ids \ |
| --with-pci-ids-path=/usr/share/hwdata/pci.ids \ |
| --with-firmware-path=/lib/firmware \ |
| --disable-introspection |
| |
| UDEV_DEPENDENCIES = host-gperf host-pkg-config util-linux kmod |
| |
| ifeq ($(BR2_PACKAGE_UDEV_RULES_GEN),y) |
| UDEV_CONF_OPT += --enable-rule_generator |
| endif |
| |
| ifeq ($(BR2_PACKAGE_UDEV_ALL_EXTRAS),y) |
| UDEV_DEPENDENCIES += acl hwdata libglib2 |
| UDEV_CONF_OPT += \ |
| --enable-udev_acl |
| else |
| UDEV_CONF_OPT += \ |
| --disable-gudev |
| endif |
| |
| define UDEV_INSTALL_INITSCRIPT |
| $(INSTALL) -m 0755 package/udev/S10udev $(TARGET_DIR)/etc/init.d/S10udev |
| endef |
| |
| UDEV_POST_INSTALL_TARGET_HOOKS += UDEV_INSTALL_INITSCRIPT |
| |
| $(eval $(call AUTOTARGETS)) |