| ############################################################# |
| ############################################################# |
| MIDORI_SOURCE = midori-$(MIDORI_VERSION).tar.bz2 |
| MIDORI_SITE = http://archive.xfce.org/src/apps/midori/0.3/ |
| MIDORI_INSTALL_TARGET = YES |
| MIDORI_DEPENDENCIES = host-pkg-config host-intltool webkit libsexy libgtk2 |
| ifneq ($(BR2_PACKAGE_XORG7),y) |
| define MIDORI_WITHOUT_X11 |
| $(SED) "s/check_pkg ('x11')/#check_pkg ('x11')/" $(@D)/wscript |
| define MIDORI_CONFIGURE_CMDS |
| $(TARGET_CONFIGURE_OPTS) \ |
| (cd $(@D); ./waf build -j $(BR2_JLEVEL)) |
| define MIDORI_INSTALL_TARGET_CMDS |
| (cd $(@D); ./waf --destdir=$(TARGET_DIR) install) |
| $(eval $(call GENTARGETS)) |