blob: 7f70eeece246c63d8cd82253e663c2dcb96e443d [file] [log] [blame]
FIRMWARE_SITE=repo://vendor/firmware
define FIRMWARE_INSTALL_TARGET_CMDS
# BR2_* strings contain wrapper quotes; remove them using the $tmp
# assignment, so that wildcards can work.
set -e; \
tmp=$(BR2_PACKAGE_FIRMWARE_FILENAMES); \
for d in $$tmp; do \
for dd in $(@D)/$$d; do \
dir=$$(dirname "$(TARGET_DIR)/lib/firmware/$$d"); \
mkdir -p "$$dir"; \
cp -P "$$dd" "$$dir/"; \
done; \
done
endef
$(eval $(call GENTARGETS))