blob: 98c0ab7bcbc2e91697f0813ec79a9757a77fd079 [file] [log] [blame]
#############################################################
#
# bmon
#
#############################################################
BMON_VERSION = 2.1.0
BMON_SOURCE = bmon-$(BMON_VERSION).tar.gz
BMON_SITE = http://distfiles.gentoo.org/distfiles
ifeq ($(BR2_PACKAGE_NCURSES),y)
BMON_DEPENDENCIES += ncurses
else
BMON_CONF_OPT += --disable-curses
endif
ifeq ($(BR2_PACKAGE_ALSA_LIB),y)
BMON_DEPENDENCIES += alsa-lib
else
BMON_CONF_OPT += --disable-asound
endif
ifneq ($(BR2_PREFER_STATIC_LIB),y)
# link dynamically unless explicitly requested otherwise
BMON_CONF_OPT += --disable-static
endif
define BMON_UNINSTALL_TARGET_CMDS
rm -f $(TARGET_DIR)/usr/bin/bmon
endef
$(eval $(call AUTOTARGETS))